[Windows] Invisible Helmet Bug
Closed, ResolvedPublic

Description

What is happening:
Upon putting the helmet received from the speech quest in cloudopolis, on a Fillies head, the mane disappears and so does the helmet making it seem like your character is bald. This can freeze your game and may also cause your character's tail to start "freaking out". It does not directly affect gameplay but it is distracting. Upon relogging and taking the helmet off, my mane was back but the helmet was still invisible.

What should be happening:
Upon putting the helmet on, the helmet should appear on the filly's head and seem tangible.

Steps to reproduce the issue:

  1. Create filly
  2. Complete Speech quest in Cloudopolis
  3. Apply helmet directly to the forehead
  4. Observe.
  5. Relog
  6. Take it off

Game client version:
Windows, normal launcher.

Screenshots:
https://cdn.discordapp.com/attachments/257650754360180737/257867774771068928/unknown.png
https://cdn.discordapp.com/attachments/257650754360180737/257868263931904000/unknown.png

Currently, the helmet works for foal models. It does not work for filly models

Currently, the helmet works for foal models. It does not work for filly models

So... it works for colts, you mean?

Rattletrap closed this task as Resolved.Sep 10 2017, 3:53 AM

This issue has been resolved as of OAR build.

Cogsworth added a subscriber: Cogsworth.EditedSep 26 2017, 10:26 AM

This issue is back. My filly stays bald when I remove the helmet till I change rooms then she has a mane again.

This has been happening to me, too. Logging out and back in again gets her mane back, but the helmet is still invisible.