Friendly dragon
Closed, ResolvedPublic

Description

What is happening:
By going up and down from trees it`s possible to make enemies non hostile and unkillable.
The problem is server specific. Relogging doesn`t solve the problem. Server restart does.

Steps to reproduce the issue:
Keep changing the altitude from the one where the enemies are. It doesn`t happen all the times.

Game client version:
0.1.1

Reproduced by:
Blue Charm

Reproduced on:
windows10 64bit

Screenshots:

Fess added a subscriber: Fess.Dec 23 2016, 3:25 AM

Not dealing any damage probably caused by you being fainted (check the chat).
There is a huge delay between being fainted on server and an appearing of respawn dialogue.

So changing altitude is not the case here, it's all about server lags.
When server is freshly restarted, the combat system seems more or less alright, but otherwise such delays are quite reproducable.

i`m not sure that was the problem since i was able to damage every other enemy in the map, that message was given by an earlier faint, i`ve gone to the dragon after the respawn, i just didn`t check the message. i`ve also reproduced the exact same bug with timberwolfs and in that footage there isn`t any similar message and i was able to damage them until i got on a tree.

Fess added a comment.EditedDec 24 2016, 9:41 AM

Alright, my bad, you're right - unlikely it was caused by being fainted, because you wasn't fainted.

When mobs lose you, they're trying to return to their spawn area.
During that period they're immortal and they ignore enemies.

Could it be possible that that dragon stuck on the tree and lost you?
For some reason (bad pathfinding!) he was unable to return to his spawn area, thus he achieved his eternal enlightenment and immortality :D

Wolfes are strange though, because they stuck at the clear field.
Seems like AI sometimes can't find his way to spawn area? :O

Rattletrap closed this task as Resolved.Jan 27 2019, 2:06 AM
Rattletrap added a subscriber: Rattletrap.

Issue has been fixed in more recent builds.