Current health sets to 500 upon levelling up.
Closed, DuplicatePublic


What is happening:
Whenever my pony levels up, their current health seems to set back down to 500, and regenerate back to full over time. With 2000+ max health, it suddenly plummets all the way down to 25% or less, which would definitely spell trouble for a high level pony leveling up in the middle of a fight against multiple high level enemies.

What should be happening:
The health should either restore to maximum upon leveling up (probably what's intended), or not change at all.

Steps to reproduce the issue:
Level up. Initially, I thought this just happened upon leveling Combat up, which increases a pony's maximum health, but I leveled up Magic once and my life bar emptied itself out once again.

Game client version:
v0.1.1 Alpha Release

Reproduced by:

Reproduced on:
Windows 7, 64-bit OS

Crash logs or exceptions generated:


Rattletrap closed this task as Resolved.May 9 2017, 1:34 PM
Rattletrap added a subscriber: Rattletrap.
This comment was removed by Rattletrap.
Rattletrap reopened this task as Open.Jun 21 2017, 4:51 AM