Heartlands River Allows for Unicorns to Teleport Under Water
Open, Needs TriagePublic

Description

What is happening:
As a Unicorn, I am able to teleport beneath the water texture of the river in the Heartlands.
I receive no collision, and can walk around beneath the water texture as if I were on dry land.
Beneath the water texture, there appears to be nothing preventing me from teleporting to the land mesh underneath.

What should be happening:
Possibly teleporting onto the surface of the water, not under the texture.

Steps to reproduce the issue:
As a Unicorn, stand on one of the riverbanks near the waterfall of the Heartlands. The nearest one as you enter from Cloudopolis, which should be on your left. Attempt to teleport to the opposite riverbank, and it should result in you teleporting to the bottom of what appears to be a dry valley, when in reality, you are under the river.

Game client version:
Build v0.1.1

Reproduced by:
N/A No others as far as I am aware of.

Reproduced on:
Windows 10 (64bit) on an ASUS ROG GR8 PC
Amareicas server

Crash logs or exceptions generated:
N/A

Screenshots:

Blue_Cola updated the task description. (Show Details)Dec 16 2016, 5:17 PM

Have managed to reproduce this bug on client version 1.4, running on 64-bit Linux. It appears to affect multiple locations throughout Heartlands rivers (some locations I cannot teleport to, but when I do teleport, I end up underwater).

Ponydale river does not have this bug (teleporting there sends me to the river surface as per expectation) and nor do Cantermore rivers (though in a lot of Cantermore water, such as the lake behind the station, one cannot teleport at all).

If I approach close to the water surface from underneath (such as by walking up the bank, or jumping if I am close enough) then my foal is rapidly expelled from the water in a very large jump. However, as long as I stay well under the water, I find that I can scroll (and teleport) back and forth along the river bed to my heart's content.

The bug seems to trigger most when trying to teleport into water a long way from me.

Xiron closed this task as Resolved.Jul 6 2017, 1:29 AM
Xiron reopened this task as Open.Jul 23 2017, 3:21 AM
Xiron added a subscriber: Xiron.

I jumped and assumed this one another one of those 'river hole' reports because there was a hole around the area of the screenshot in OP. But no, turns out you can for whatever reason, still teleport underneath in some spots as I display in this video here: