Inventory drag and drop
Closed, ResolvedPublic

Description

What is happening:
When i drag and drop an item from my inventory to the appropriate slot the icon remains on the screen while the item icon disappear from the inventory.
Closing and opening the inventory again makes the item icon reapper but the exceding icon will remain on the screen.
The only way to fix the issue other than log off is to interact with the real item by dragging it, that will reset the icons.
It seems to happen even with multiple icons. Another problem is that the bucket is wooden while the one in the icon is made of metal.
(Also i`m slightly disappointed because i can`t wear the bucket on the head as the item description hints)

What should be happening:
If a drag and drop system is intended the item should be equipped

Steps to reproduce the issue:
Take an item from inventory and drag it in the appropriate equipment slot
(tested with the bucket and leg armor)

Game client version:
0.2 and 0.1.1 tested on both

Reproduced by:
Blue Charm

Reproduced on:
windows10 64bit

Screenshots:

Something similar happened to me
The description mentioned that the bucket would make a cool helmet so I click and dragged it to the head slot.
Now I have a floating bucket icon.

Reproduced on:
Windows 7 64bit

justin reassigned this task from justin to Natfoth.Dec 17 2016, 10:04 PM
justin lowered the priority of this task from Needs Triage to Wishlist.
justin edited projects, added client; removed loe-team.
justin edited subscribers, added: garophel, justin; removed: loe-leads.
Dorumon21 added a subscriber: Dorumon21.EditedSep 12 2017, 9:33 AM

Vers. 0.1.8, window 64x

Another problem with drag and drop in the inventory I found recently, since it related to drag/drop.

You can make certain items disappear, but it not really gone, it just not visible from bag and weird things happen.

First step
I using cherry pie and ruby for this, first drag the ruby and attempt to place it on cherry pie, it'll go back to its spot.

Second step
In this step, I then drag the cherry pie past the ruby.


If you do this, the ruby will be gone, this can happen on any item you do this with. If you attempt to move the cherry pie into the ruby spot, the cherry pie will be unable to move from it previous spot no matter how much you try

The good news is the bug is only temporary, the items will be back to normal when you leave a area, or log back in.

Rattletrap closed this task as Resolved.Jul 18 2018, 6:48 PM
Rattletrap added a subscriber: Rattletrap.

This issue has been resolved as of v3018.03.02.