Conversational user interface, Bad Flow
Closed, WontfixPublic

Description

What is happening:
When talking with Pyrite during the Mindless Violins quest, I selected a conversational option other than the default. It so happened that there was lag in waiting for the client/server to react to this, and during the lengthy pause, the default dialog option at that state came onscreen. Since there's very little feedback about whether I correctly triggered the dialog option I wanted *except* for the conversation moving forward, the fact that my own dialog changed to something 'new' could easily be interpreted as the next choice I have to make instead of just being the default for the choice I just did make. I have no idea if clicking on that erroneous dialog display is relevant, and if it eventually goes away (which it does if I wait long enough) I have no idea if I missed an important bit of dialogue. There are therefore three problems here: The lag for network response, the fact that during the lag, the default option for the current conversational choice just made comes back up for no reason introducing a massive inconsistency in user interface flow, and because there's no feedback for making choices other than moving along the conversation chain clicks on this erroneous dialog are uncertain (not just about whether the erroneous display is part of the conversation, but whether or not a click could be interpreted for the next *valid* default choice once the server gets back to updating the client)

What should be happening:
All three of these things need fixing, but arguably in the short term, having the dialog box not display the default choice for the current tier of conversation whilst waiting for a server response would remove the inconsistency of conversation and the uncertainty of clicking. Video shows the flow once I logged off and back on again, since I also ran into the bug where I stalled with an empty dialog in the middle of conversation (see my other bug on this). In this video, the 'default option' problem zips by pretty quickly, but you can see the changeover anyway, and depending on it zipping by is a bad idea. In that case I'd have no idea if I accidentally misclicked and zipped right by valid dialog.

Steps to reproduce the issue:
Conversation under high server load, I suppose.

Game client version:
Give the name of the archive from which you got this version

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Reproduced on:
List of operating systems this issue has been reproduced on, including their version number if available, and their architecture (32 bit or 64 bit)

Crash logs or exceptions generated:
If applicable, give a link to an archive containing the crash logs generated, or copy/paste exceptions you got related to this error

Screenshots:
Video shows the flow once I logged off and back on again, since I also ran into the bug where I stalled with an empty dialog in the middle of conversation (see my other bug on this). In this video, the 'default option' problem zips by pretty quickly, but you can see the changeover anyway.

https://www.dropbox.com/s/ppjgvb7nhgmh15k/2016-12-13%2012-31-13.mp4?dl=0

Natfoth reassigned this task from justin to Rattletrap.Dec 14 2016, 11:06 PM
Natfoth added a subscriber: justin.
Rattletrap lowered the priority of this task from Needs Triage to Normal.Dec 20 2016, 3:14 PM
Rattletrap closed this task as Wontfix.Mar 26 2017, 12:00 AM

Issue has been resolved with fixing of lag issues. No further fixes will be implemented at this time.