Rehearsal Roundup (Luster)
Closed, ResolvedPublic

Description

What is happening:
Luster will not offer the dialogue choice for the player to offer a piece of sheet music. I did complete his other quest (changeling quest) first so now he just shoos me away.

What should be happening:
Despite doing the other quest first I should be allowed to offer him sheet music, even if an alternate dialogue is required.

Steps to reproduce the issue:
Complete Luster's quest, then try to do Rehearsal Roundup

Reproduced by:
No idea, I mostly solo

Screenshots:
I can provide a short video of the quest saying Luster is the only one left to offer music to, and then him shooing me away if needed.

Rattletrap closed this task as Resolved.Fri, Feb 26, 6:13 AM

I've changed the script so that if you go to Luster again, his objective marker should resolve.
He still won't take the music, since he is not intended to be part of the total.