Evershade map bug (hole)
Closed, ResolvedPublic

Description

What is happening:
I found a hole in the map while fighting mobs accidentally. I could not get out so I wandered through the area below the map and touched a white mushroom. I was teleported beyond the barrier to the ruined castle. In fact, I was able to get across the chasm using teleportation (the spell).

What should be happening:
If this is actually a bug in the terrain, rebuild the BSP data or put a rock mesh over it so players don't fall in?

Steps to reproduce the issue:
Go to hole. Fall in hole. Touch magic mushroom but do not grow big like Mario. Explore castle.

Game client version:
Filename: legends-of-equestria-legends-of-equestria-win-lar-64bit-33.zip
In-game version: 2020.05.01

Reproduced by:
None that I am aware of. I don't really have any friends to play with.

Reproduced on:
Windows 7 Pro 64bit, final build, all updates
Gentoo GNU/Linux 64bit, updated about two weeks ago (rolling release distro built entirely from source)

Crash logs or exceptions generated:
No crashes!

Screenshots:
No screenshots. I will fire up OBS and get you a video and update this soon.

I just recorded the video. I can reproduce this every time, so either this is a secret developer teleport (come on, we had cool GM commands in the WoW alpha and beta to get around!) or genuinely a bug. If I stumbled into a developer hidey-hole, sorry!

https://youtu.be/ONgRZhmkZPw

It's not really a bug. That used to be the original path to the castle until it was replaced with a new path back in 2018, but since some older players still tried taking that path, I re-added the old one as secondary path, making both paths possible now.

Rattletrap closed this task as Resolved.Dec 3 2020, 1:30 AM