failed to establish connection - no response from remote host
Open, NormalPublic

Description

What is happening:
We just created an account this evening to play Legends of Equestria and we've been unable to get into a server. Regardless of whether we click on Europonia or Amareicas, we receive the same message: "failed to establish connection - no response from remote host".

What should be happening:
I imagine we should be taken to a screen that would allow us to create a pony.

Steps to reproduce the issue:
Open game, log in, choose server, "waiting for official Legends of Equestria server" ... waiting ... "failed to establish connection - no response from remote host"

Game client version:
Next to the MacOS download link, it says "Latest update: v2020.03.03"

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Reproduced on:
List of operating systems this issue has been reproduced on, including their version number if available, and their architecture (32 bit or 64 bit)

Crash logs or exceptions generated:
If applicable, give a link to an archive containing the crash logs generated, or copy/paste exceptions you got related to this error

Screenshots:
If applicable, give a direct link to screenshots/GIFs/videos of the issue, annotated to show exactly what's going wrong

endler created this task.Jul 22 2020, 12:38 AM
Cyanspark lowered the priority of this task from Needs Triage to Normal.Oct 19 2020, 1:37 AM
Cyanspark added a subscriber: Cyanspark.

Check your firewall settings, perhaps? System Preferences > Security and Privacy > Firewall > Firewall options