[PLEASE HELP] "The Choices We Make" is not completeable!
Closed, ResolvedPublic

Description

What is happening:
The dialogue to get the package from Halite is nonexistent.

What should be happening:
There should be dialogue to get the package so that the quest can continue

Steps to reproduce the issue:
Start the "The Choices We Make" quest and try to talk to halite to get the package.

Reproduced by:
me

Screenshots:
https://i.imgur.com/At2XyBj.png
https://i.imgur.com/ifjqM4R.png
https://i.imgur.com/dFF3BVs.png
https://i.imgur.com/oFirvJz.png

JinxArdor created this task.Oct 3 2019, 7:14 PM

On the discord I was told this was fixed, but it is still not working.

Have the same problem with this quest. It makes sense to me is also messed up.

Rattletrap closed this task as Resolved.Wed, Nov 6, 6:28 AM

Make sure that you are talking to Halite, not to Silicon. If you click on Silicon, you will not get the proper dialogue, since you are supposed to be talking to Halite. Silicon starts with similar dialogue, but does not include the options for the Choices We Make, since you are supposed to start by talking to Halite.
I have tested that point in the quest and it worked for me.

I did talk to Halite and it still didn’t work for me. I tried both of the ponies :(