Full Yellow Jacket
Closed, ResolvedPublic

Description

What is happening:
I cannot complete this quest as it was bugged a long time ago when I was a foal and couldn't complete it, now I am a groan pegasus and cannot go back to complete this quest. I need to complete this quest so I can continue onward towards the artisan quest to unlock my artisan skills.

What should be happening:
I should have been allowed to complete these previous quests so that I can proceed onto the artisan introduction.

Steps to reproduce the issue:
I am a grown pegasus, but this quest can only be completed as a foal.

Reproduced by:
N/A

Screenshots:
https://i.ibb.co/S7jKRGx/Untitled.png

Related Objects

Tykune created this task.Jun 7 2019, 8:00 AM
Tykune added a comment.Jun 7 2019, 8:50 AM

Upon talking with someone, apparently not completing this quest had likely left me without a talent mark.

The problem is that I never got the flying talent mark (ie It didn't unlock all my flying skills), so technically I never completed the quest. If I erase the quest marker, then I'll not have an talent marks?

The quest was bugged at that time resulting in the fact that you did finish it by growing up.

If you grew up, then you completed at least one of the other Talent Mark quests, since the only way to become an adult is to complete one of those quests. I note from your picture that there are a large number of other quests that you have also completed (they will show if you scroll down using the sidebar there). Players may currently only complete one Talent Mark quest to become an adult.
If you wish to create an artisan pony, then you will need to start over as a foal with a new character.

If you wish to remove Full Yellow Jacket from your quest list, there will be an option to do so with Old Quest Marker Fix after the next server reset. It will show as the option, "Grew up, but Full Yellow Jacket is still active". Choosing this option will not remove your pony's talent mark, nor will it remove any skills that you have already acquired.

Rattletrap closed this task as Resolved.Jun 17 2019, 8:47 PM