Drop and Experience from Dragons and Golems does not happen
Closed, ResolvedPublic

Description

What is happening:
When defeating a level 50 Rock Golem or a Dragon, character does not receive any experience, and loot chest does not appear. This happens almost 75 - 80% of the times fighting those mobs. Sometimes it works fine, but very rare.

What should be happening:
Experience and Drop should be given every time mobs are defeated.

Game client version:
2018.10.01

Reproduced on:
Windows 32 and 64 bit

Puzzle created this task.Jan 1 2019, 12:31 PM
Puzzle updated the task description. (Show Details)Jan 1 2019, 1:00 PM
Lens_Flare added a subscriber: Lens_Flare.EditedJan 7 2019, 10:32 PM

lvl50 Dragons working fine is even more rare than that. Sadly it appears at the moment they are the only source of some sunlight armor parts for which there's a high demand given the introduction of pearlescent and iridescent armors crafted from just that armor.
Since players really need the sunlight armor now I'd say that is a very serious problem with the game atm.

Yeah it's pretty bad since most people level off Dragons at 30 + but now with the new armor it's making it almost impossible to get Sunlight so you can craft the new armors. The Golems are not a big issue since the Level 45 are working fine other then trying to get Ingots for crafting but the Dragons are almost game breaking, since they drop a lot of the crafting items, have good experience for higher level's and drop the Sunlight armor this bug is going to hold ponies back a lot. Hopefully LoE can find/fix it soon, i know a good amount of ponies that are upset about it.

Rattletrap closed this task as Resolved.Jun 2 2019, 5:45 AM
Rattletrap added a subscriber: Rattletrap.

Fixed as of build v2019.01.02