The magic of ordinary Neighs
Closed, ResolvedPublic

Description

What is happening:
The pony I need to meet inside the forest is not there. I was doing this quest then switched to doing the artisan quest. After completing the artisan quest the pony grew up. Not sure if the pony was inside the forest before starting the artisan quest. Also have some seemingly unrelated quest marker at every train station but doesn't go anywhere its just staying at the stations.

What should be happening:
Either the pony should be inside the forest to complete the quest or the quest should drop from my quest menu since I'm not a filly anymore.

Steps to reproduce the issue:
Start the magic quest until after you get he magic bolt but before entering the forest.
Start and finish the artisan quest

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Screenshots:
If applicable, give a direct link to screenshots/GIFs/videos of the issue, annotated to show exactly what's going wrong

Vancas created this task.Dec 16 2018, 5:04 AM

The pony in evershade takes a little time to load but should be there. Give it time

I've been waiting a while and it doesn't show up. Is there a way to drop the quest seeing as I grew up and graduated already

Rattletrap closed this task as Resolved.Jan 21 2019, 10:11 PM

Once you have grown up (completed a Talent Mark quest), you cannot complete any other Talent Mark quest.

Closing this up.