Quest marker over teacher after graduation
Closed, ResolvedPublic

Description

What is happening:
After completing “The first day of our pony lives” a quest marker shows up over our old teacher. Talking to them will remove the marker from the mini-map, but not from above her head. The quest log shows the quest as being completed. Logging out and back in again only brings back the quest marker on the mini-map and does not affect the marker over their head at all.

I have managed to recreate this with both a pegasus and an earth pony. I have not attempted it with a unicorn yet. Not sure if knowing would help or not, but my pegasus got her talent mark in healing and my earth pony got her talent mark in animal care.

What should be happening:
No quest marker should appear above your teacher's head or on the mini-map after you have graduated.

Steps to reproduce the issue:
I went through the whole talent mark process, completed "The first day of our pony lives", and then returned to my teacher. There happened to be a quest marker above their head and corresponding location on the mini-map.

Screenshots:
These screen shots are from after the quest is over and the question marker appearing over their heads.

I created two different albums (one for each of the two ponies I did this with). The only difference between picture 1 and picture 3 of each album is the presence or lack thereof a quest marker on the mini-map. Picture two of each album is just to show there was only one choice of dialogue to pick (and also to show what happened between pics 1 and 3).

Pegasus Screenshots:
https://photos.app.goo.gl/zT36LSPsMncTyh8CA

Earth Pony Screen shots:
https://photos.app.goo.gl/V4iFAddgmp4orecY9

Related Objects

I was just talking to someone in game and they told me that the Wizard pony in Cantermore has a fix for this. Sorry for taking up your time. I'd delete this myself to save you the effort, but I can't seem to figure out how.

hello there, in cantermore next to the trainstation, there is Old Quest Marker, he fixes leftover "!" marks. When you talk to him search for an option that says "windhover,starburst,.... leftover marks" click it and then restart. See if this helps.

Thank you. I think that's the same "wizard" pony I was talking about. I'm not really good at using phabricator yet, but I love the game and it seems like this is the only way I can support the creators. I really appreciate your help. =^.^=

Rattletrap closed this task as Resolved.Jan 21 2019, 8:39 PM

Closing this up, since it has been resolved.