Transfusion Bug
Closed, ResolvedPublic

Description

What is happening:
I acccedently clicked the level 10 mass transufion and it activated without the prequisites. It also automaticly activated Transfusion even tough i don't have 500 tp in medical. Nothing else is activated not even mass transfusion level 1. Attempting to activate Mass tranfusion level 1 did nothing. Very posssible the tranfusion line is broken completly now. My Medical is at level 14. Transfusion cost 500 tp.

What should be happening:
I should not have transfusion at all at this time.

Steps to reproduce the issue:
This is completly an assumption based on what i thinks happing.
Create a new character (talent anything other than medical) and level him/her up to 10 medical without investing in any medical (using quest). Then try to activate level 10 mass tranfusion without anything else learned in medical.

Game client version:
2018.03.02

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Reproduced on:
List of operating systems this issue has been reproduced on, including their version number if available, and their architecture (32 bit or 64 bit)

Crash logs or exceptions generated:
If applicable, give a link to an archive containing the crash logs generated, or copy/paste exceptions you got related to this error

Screenshots:

ErebusXero updated the task description. (Show Details)Jun 18 2018, 10:49 PM
Tripy998 raised the priority of this task from Needs Triage to High.Jun 19 2018, 11:49 PM
Tripy998 added a subscriber: Tripy998.

Changing to high priority as Magic tp and other tps breaking has been previously addressed, apparently to no end.
Also because this can be used to gain skills outside of the level needed to get them.

Rattletrap reassigned this task from justin to Cyanspark.Jun 27 2018, 7:36 AM
Rattletrap added a subscriber: justin.

Addressed in upcoming build.

Rattletrap closed this task as Resolved.Jul 18 2018, 3:59 PM
Rattletrap added a subscriber: Rattletrap.

Closing since it will be addressed in upcoming build.