Unusual copy/paste behaviour on linux
Closed, WontfixPublic

Description

What is happening:
When attempting to paste text into an input box, it will 'lag' behind and take two attempts.

While this bug is present everywhere, the first screen seems to have its own 'buffer', so passwords pasted into the login screen thankfully aren't carried into the game.

Copying from chat works normally, as does pasting things copied from the chat.

What should be happening:
Things copied outside the game should be pasted normally into chat, with no delay.

Steps to reproduce the issue:
(Assuming a fresh game instance)
Copy/Paste thing A into chat -> Nothing. Second paste attempt -> 'A' is pasted into chat

Copye/Paste 'A' into chat -> Nothing. Copy Paste 'B' into chat -> 'A' pasted. Third paste attempt -> 'B' pasted into chat

Game client version:
2018.03.02

Reproduced by:

Reproduced on:
Linux 64bit - Ubuntu 16.04

Crash logs or exceptions generated:

Screenshots:

Rattletrap closed this task as Wontfix.Jun 29 2018, 2:55 AM
Rattletrap added a subscriber: Rattletrap.

You should not be copying/pasting things into our chat on a regular basis. Our chat is designed for players to type their replies into the box. The delay may be due to our filters attempting to parse the copy-pasted information.