Duplicate NPC (double, two, clone, non-player character)
Closed, ResolvedPublic

Description

What is happening:
It appears that some NPCs exist twice at the very same spot.
The ones I discovered are Odds 'n' Ends next to Midway Village and Stool Pigeon at Cantermore's castle.
It is likely that there are more.

What should be happening:
There should be only a single NPC/pony/entity/model instead of two.

Steps to reproduce the issue:
Go to the NPC in question, observe them and you'll see the other one when one of them performs the idle animation.

Game client version:
0.1.9, 0.1.10 (current)

Reproduced by:
Myself (Moon_Flower)

Reproduced on:
Windows 10 Home 64-bit (10.0, Build 16299)

Crash logs or exceptions generated:
Not applicable.

Screenshots:
Odds 'n' Ends, The Heartlands, next to Midway Village


Stool Pigeon, Cantermore, Cantermore Castle

Crimson_Tail added a subscriber: Crimson_Tail.EditedFri, Jan 5, 5:21 PM

Should be fixed, issue will still be open until the fix is confirmed after a server restart. For courtesy, the next time you open an issue about NPCs or quests, please be sure to use "Create Quest Bug".

Update: Stool Pigeon's cloning seems to persist across restarts, but Odds 'n' Ends may have been fixed

Stool pigeon is duplicated for me as well. I looked through all the other areas, and he seems to be the only one.

Solved the issue, Stool Pigeon had two differently named files.

Moon_Flower added a comment.EditedFri, Jan 5, 10:14 PM

Should be fixed, issue will still be open until the fix is confirmed after a server restart. For courtesy, the next time you open an issue about NPCs or quests, please be sure to use "Create Quest Bug".

Okay, I try to remember that.
Please not that the tutorial and the platform's interface exclusively say Quest Bug, you might want to change that to something like "Quest & NPC Bug".
I'm certain that other people might have the same train of thought.

I will look at those two NPCs today or tomorrow to report if it is fixed.

Rattletrap closed this task as Resolved.Fri, Jan 5, 10:42 PM

Not resolved.

Odds 'n' Ends is fixed, but Stool Pigeon isn't.

Screenshot taken just now:

Moon_Flower added a comment.EditedFri, Jan 5, 10:53 PM

How to reopen the task?

Okay, it is fixed on both now.
Crimson_Tail explained to me that it takes sometimes a while to take effect, as the server needs to be restarted.
I re-rechecked now and both ponies are doing fine now.