Hearth's Warming Costume Unequippable
Closed, ResolvedPublic


What is happening:
The items received from the quest "Dashing Through the Snow" are still considered Quest items, and cannot be worn.
However, I have witnessed another player that managed to wear them, so it is unclear whether this bug is triggered by different dialog choices, or just slight differences in the versions between platforms. (This is the Linux version.)

What should be happening:
The items should be wearable, and I believe they are meant to be treated as normal items, not quest ones.

Steps to reproduce the issue:
When I took the quest from Ensemble, I already had all the required lantern crystals and timberwolf branches. This may have some relevance to the bug. In the dialog options, I expressed some shock at the price of one thousand bits (since I like to roleplay a character, not necessarily optimize responses), but I accepted his reasoning and accepted the price. Other than that, everything was a "normal" runthrough of the quest.

Game client version:

Reproduced on:
64-bit Linux Mint 18.2 Cinnamon


(Note that the screenshot in question displays two separate glitches. I will make a separate report for that one.)

Asriel created this task.Dec 30 2017, 3:58 PM
Rattletrap closed this task as Resolved.Jan 7 2018, 9:59 AM
Rattletrap added a subscriber: Rattletrap.

Move the quest items from the quest inventory to normal inventory. That allows them to be used and worn,