Chat filter is oversensitive
Closed, ResolvedPublic

Description

What is happening:
This stupid thing is blocking many perfectly good sentences.
"figured out. It's that" - blocked for including TITS.
And on and on it goes. WAY TOO MANY innocent sentences are being filtered, while perfectly vile stuff you haven't thought of gets past.

What should be happening:
freedom of speech. Lose the damn thing.

Steps to reproduce the issue:
-Message Filtered- (oh dear - it's filtered the steps required)

Game client version:
any and every version of the game.

Reproduced by:
every poor sucker that has ever typed in the chat box.

Reproduced on:
all of them.

Crash logs or exceptions generated:

The only crashes are when frustrated ponies hit their keyboards.

Screenshots:
I'm sure you know what -message filtered- looks like.

garophel renamed this task from total joke of a language filter to Chat filter is oversensitive.Dec 27 2017, 9:11 AM
garophel claimed this task.
garophel closed this task as Resolved.
garophel lowered the priority of this task from Needs Triage to Normal.
garophel edited projects, added client, server; removed loe-team.
garophel added a subscriber: justin.