Strange bug with quest "It`s All About Me"
Closed, ResolvedPublic

Description

What is happening:
As soon as I entered the Crystal Empire, I had an exclamation mark on the map, I went on it, and met a pony named Autumn Breeze, over which an exclamation mark was hovering. I talked to her and the quest "It`s All About Me" , I made the first item (I brought a cookie), talked to her, understood nothing, looked in the magazine, but there was no second item, just no.
I was surprised and went to Wikipedia to see how to do it. I did as it was written there, I finished the quest. But an exclamation mark was hovering over the pony, but it was not on the map. The quest was completed.

What should be happening:
The exclamation mark should not have appeared on the map at all, he appeared there himself.

Steps to reproduce the issue:
All steps were written in the first paragraph, I hope this will be enough.

Reproduced by:
Unfortunately, I do not know who else could have such bugs, but they definitely had others.

Screenshots:


Did you earlier complete the quest Rehearsal Roundup? If so, then the quest marker is left over from that. A fix for extra quest markers is in the works, but not yet completed.

Rattletrap closed this task as Resolved.Apr 3 2018, 12:17 AM

Closing this up since nopony replied and the issue has been fixed in more recent builds.