Jumping- Stamina bar dropping issue
Closed, ResolvedPublic

Description

What is happening:
When I sprint and then jump, the stamina bar keeps decreasing the same way as if the pony was still sprinting in midair. The decrease can't even be stopped until the pony hits the ground again. That way when I for example jump of the cliff with my pegasus after a short sprint, it is completely exhausted even before it hits the ground, so it can't even fly...
This seems a bit strange given the fact that when I don't sprint before the jump, the stamina bar even incrases.
The same thing apply for sprint-flying x normal flying- When I fly normally and pegasus gets exhausted, it will recover stamina while falling down. When I sprint-fly, it does not.

What should be happening:
Since the pony is not moving while in the air, the stamina bar should stop decreasing (Perhaps after some time, so it won't be used to boost sprint range)

Steps to reproduce the issue:
Works every time.

Game client version:

Reproduced by:

Reproduced on:

Crash logs or exceptions generated:

Screenshots:

Ferro_the_King updated the task description. (Show Details)
Rattletrap closed this task as Resolved.Dec 3 2020, 8:08 AM
Rattletrap added a subscriber: Rattletrap.

Stamina is working as designed.