It Belongs in a Museum (cat quest) start bugged within Mindless Violins AND can never be started
Closed, ResolvedPublic

Description

What is happening:
If the quest Mindless Violins is running and I'm able to talk with Pyrite about the statue, 1 of 2 things will happen: A known bug where the quest It Belongs in a Museum starts before Mindless Violins is completed, but continuing the quest will be blocked until Mindless Violins is completed (check the bug in the wiki page of It Belongs in a Museum) or a bug which happened to me 1 hour ago (and which seems to appear since bug fix of T1765):

Pyrite tells me to see Fire Opal to talk about the statue, but the quest did not start. After this, Pyrite will tell me over and over again to see Fire Opal if I talk with him, and the quest will not start. And Fire Opal will ignore me. Finishing the quest Mindless Violins doesn't change anything.

This bug appears since the fix of T1765!

UPDATE: I tried it with another character. Noopony can start the quest It Belongs in a Museum anymore. It doesn't matter how you do it in which way with everything or nothing completed. He will just tell you the same thing in my screenshot and the quest will never start. I'm glad the bug is so heavy, because you're forced to fix that quicker.

What should be happening:
In the wiki, completing Mindless Violins is a prerequisite to start It Belongs in a Museum. That means Pyrite must not talk with me about seeing Fire Opal within Mindless Violins. It Belongs in a Museum is not allowed to start within Mindless Violins.

I want to suggest a fair fix, because the bug already appeared to me: If you ask Pyrite about the statue, the script has to check if the quest is truly running for the player or not (check my screenshot; no quest running). If it's not running, the script will attempt to make the quest start (reset).

Steps to reproduce the issue:

  1. To get the highest chance that this bug will happen, go as Pegasus
  2. Start Mindless Violins
  3. Find out that this is a statue you were carrying with you
  4. Go to Pyrite
  5. Talk with him about the statue
  6. Ask him about the statue while the quest Mindless Violins is still open

Result: 7. Either It Belongs in a Museum starts within the quest still running or this bug happens where you can never ever start It Belongs in a Museum until it's fixed

Reproduced by:
Me. I ran into the bug again because it's havier as I expected (see UPDATE).

Screenshots:

You see, at this moment, Pyrite tells me something where a quest should be running 100 %! But there is no quest running. It's the perfect evidence.

Annri created this task.Oct 9 2017, 4:03 PM
Annri updated the task description. (Show Details)Oct 9 2017, 4:41 PM
Annri updated the task description. (Show Details)Oct 9 2017, 5:03 PM
Annri updated the task description. (Show Details)Oct 9 2017, 6:56 PM
Annri updated the task description. (Show Details)Oct 10 2017, 10:35 AM
Annri updated the task description. (Show Details)Oct 10 2017, 10:39 AM
Rattletrap closed this task as Resolved.Oct 10 2017, 6:29 PM

This issue has been fixed.

Annri added a comment.Oct 10 2017, 7:31 PM

This issue has been fixed.

I've tested it twice and no issue occurred. Splendid work.

Annri removed a subscriber: Annri.Oct 10 2017, 7:32 PM