"You are not within range" doesn't show until first entering range
Closed, ResolvedPublic

Description

What is happening:
'Not in range' won't show unless you first get in range and then back out.

What should be happening:
'Not in range' should show regardless if you have gotten near the target or not.

Steps to reproduce the issue:

  1. Target something while being out of range.
  2. Trigger an attack
  3. Approach the target (works best on one that is moving away from you)

Game client version:
v0.1.9

Reproduced by:
n/a

Reproduced on:
Windows 7 (x64)

Screenshots:

Xiron created this task.Oct 8 2017, 1:13 AM
Xiron renamed this task from "Not In Range" doesn't show until first entering range to "You are not within range" doesn't show until first entering range.
Xiron updated the task description. (Show Details)
Maze added a subscriber: Maze.May 6 2018, 2:34 PM

It is my understanding that "*You are not within range*" only shows up on client-server desynchronization. Most often, the client and the server hold slightly different positions for a particular object. Sometimes it happens that objects are further apart on the server than they are on the client. And that is when you might appear to be in range on your screen, yet when you trigger your attack the server responds that you can't do that because you are too far away. This warning appears on your screen then.

Rattletrap closed this task as Resolved.Jun 28 2018, 3:04 PM
Rattletrap added a subscriber: Rattletrap.

This issue has been resolved in recent game builds.