How to fix Stored Strike??
Closed, ResolvedPublic

Description

What is happening:
We all know Stored Strike is overpowered on the "over 9000" scale. When i was lv 19 Earth pony i could take down a lv 50 dragon. In no RPG ever should that be feasible. I find the problem is in the stacking. Stored Strike goes up to 100 stacks with no bonuses applied. I feel this is causing the issue.

What should be happening:
Stored Strike should be capped by its own skill tree. It makes much more sense that when first unlocking the skill, it should only stack to 10, and scale of the stack would be based on perhaps how much health the pony has left.

Pony has 100 health and unlocked Stored Strike. Enemy has 100 health. Enemy has struck pony for 50 damage, Pony has 50 health remaining, Stored Strike has gone up to 4 or 5 stacks. Enemy struck pony for 40 damage. Pony has 10 health remaining, Stored Strike should be at 10 stacks. Pony uses Stored Strike, damage to Enemy is twice what was stored, so 180 damage to enemy, obviously Pony wins, but at the cost of almost losing/fainting.

(I feel this would also limit the use of this ability so that other abilities become more common to use, and thus debug, because everyone is being told to just use Stored Strike right now and Triage for self healing)

Perhaps then the bonuses applied to Stored Strike would be upping the damage output (like perhaps start at 2x, at 10 stacks, then 2.5x, 3x at 50 stacks, or however you would like to do it but max out at 5x at 100 stacks), and requiring less percentage of health to be lost before adding a stack, (9% health lost for one stack at initial ability unlock, and top out at 5% health lost for one stack) although maxed out, i feel it should still cost about half a pony's HP before Stored Strike stacks max out. (course the combat level should be at 50 by this point)

Steps to reproduce the issue:
Give a list of all steps leading to the issue, from the launch of the game to the issue

Game client version:
Currently Build 0.1.8

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Reproduced on:
Windows 10 64 bit

Crash logs or exceptions generated:
If applicable, give a link to an archive containing the crash logs generated, or copy/paste exceptions you got related to this error

Screenshots:
If applicable, give a direct link to screenshots/GIFs/videos of the issue, annotated to show exactly what's going wrong

Rattletrap closed this task as Resolved.Fri, Mar 15, 4:31 AM
Rattletrap added a subscriber: Rattletrap.

Stored Strike has been changed in more recent builds.