Issue with Objective Markers Remaining if Steps in Quest Are Skipped.
Open, Needs TriagePublic

Description

What is happening:
Describe here what is currently happening
If you skip a step in any part of a quest and still complete it, it will leave a permanent ! on your map and above the pony's head that gave you the quest. For example, this happens with the quests "It belongs in a Museum" or "Mindless Violins" and either "Good Egg" or "Birthday Wishes"

What should be happening:
Describe here what should be happening instead
The ! should disappear after the quest is completed.
The ! should not be there after I completed their quests.

Steps to reproduce the issue:
Give a list of all steps leading to the issue, from the launch of the game to the issue
Just skip a part of a quest and complete it and it will leave a permanent ! on your map and above the pony who gave you the quest.

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Screenshots:
If applicable, give a direct link to screenshots/GIFs/videos of the issue, annotated to show exactly what's going wrong

https://imgur.com/a/wXjGW

RowanTheDeer updated the task description. (Show Details)Sep 30 2017, 4:19 AM
RowanTheDeer updated the task description. (Show Details)Sep 30 2017, 1:42 PM
RowanTheDeer updated the task description. (Show Details)Oct 1 2017, 2:26 AM
RowanTheDeer updated the task description. (Show Details)Oct 1 2017, 2:31 AM
Rattletrap closed this task as Wontfix.Oct 5 2017, 5:41 AM

Please issue individual reports of specific examples of quest names and where in the quests the issue is occurring, then we can correct the issues. Otherwise, this report is too generalized to effect specific fixes and is going to be closed.

RowanTheDeer updated the task description. (Show Details)Oct 5 2017, 1:18 PM
RowanTheDeer updated the task description. (Show Details)Oct 5 2017, 10:26 PM
Rattletrap reopened this task as Open.Oct 6 2017, 7:15 PM
Rattletrap renamed this task from Quest Glitches to Issue with Objective Markers Remaining if Steps in Quest Are Skipped..Oct 6 2017, 7:18 PM

I am going to get screenshots when I can.

RowanTheDeer updated the task description. (Show Details)Oct 7 2017, 5:57 PM

How do I make the LoE screenshots into a link?

RowanTheDeer updated the task description. (Show Details)Oct 7 2017, 6:04 PM

Nvm I got the screenshots

Issue with It Belongs in a Museum should be fixed after next server restart.

Will my !'s disappear after it is fixed or do I have to make a whole new character?