Abilities on Hotbar stop working when Instance resets or player transitions to new areas
Closed, ResolvedPublic

Description

What is happening:
Skills set to hotbar stop responding at random intervals when instance either resets or I transition over to a new area (say going from Cantermore to Ponydale).

I am able to restore all skills by opening the skill book and drag/dropping the skills (say magic arrow from the magic skillset ) back to the hotbar.
Main issue that I cannot fix though is the Teleport Ability for the unicorn (as it's not in any skill book to restore).
Shutting down the game completely and restarting does fix the issue.

What should be happening:
Skills to the hotbar should remain functioning regardless of resets or map transitions.

Steps to reproduce the issue:
Due to the nature of the issue being random, there's no fixed value as to when it will glitch up.

Launch game and create character.
Drag/drop skills to hotbar.
Transition randomly to new areas, playing normal. Eventually one of these transitions or zone resets will cause hotbar to stop working.

Game client version:

Launcher (Windows only) Latest update: 2017-09-09

And

Windows x64 Latest update: 2017-09-22, e895688

Tried both clients, saved on different drives with a fresh delete of the appdata =>LocalLow => LoE => hotbar.json

Reproduced on:
Windows 7 Ultimate - 64 Bit

Had this issue too lately, can't use skills during gameplay sometimes, only emotes.
Only re-launching game client can help sometimes,although rooms can change quite fast and skills could get broken again.

I've encountered that bug on latest OAR build of 22nd September.

most likely you can fix this by changing rooms again when hotbar is not working, I only had this once and while the above fix can work, simply changing rooms can often times fix it much quicker. It pretty random however when it decides to not let you use the skills (even tho emotes work)

Sadly, when the hotbar stops working for me. Changing rooms, areas, nothing works short of either a full reboot, or manually replacing every skill on the hotbar (outside of teleport which is not possible to fix). Oddly enough, all emotes on my 2nd hot bar work just fine.

Sadly, when the hotbar stops working for me. Changing rooms, areas, nothing works short of either a full reboot, or manually replacing every skill on the hotbar (outside of teleport which is not possible to fix). Oddly enough, all emotes on my 2nd hot bar work just fine.

You can get back teleport by resetting your hotbar.

Press Windows + R and enter this

%appdata%..\..\LocalLow\LoE\Legends of Equestria

Press Enter then delete hotbar.json.

You should get back your tp after that.

You can get back teleport by resetting your hotbar.

Press Windows + R and enter this

%appdata%..\..\LocalLow\LoE\Legends of Equestria

Press Enter then delete hotbar.json.

You should get back your tp after that.

Hi RavidEv.

Yup, know about that already. That's what I've been doing (though with the current problem that's occasionally occuring it's easier to just shut the game off and restart, that fixes it without having to delete the hotbar.json file).
Just bringing the odd issue of the hotbar randomly stops working to the team :)

I am able to reproduce the same glitch by:

  • Logging into my account
  • selecting any server, selecting an Unicorn character, and playing
  • logging out
  • logging back in
  • selecting any server, selecting an Earth Pony character, and playing

I'm not sure if switching from/to any other character causes the same thing to happen...

Playing on Windows 10 Home 64-bit with the win64_0.1.8.5_e895688 client.

I have this problem with my Pegasus that I created on 23 September, but not my Unicorn I made opening weekend.

Should anyone not want to go through the pain of resorting their hotbar after the deletion of hotbar.json

  1. Create a copy of hotbar.json and place it anywhere other than where the original file would reside.
  2. Exit the game and delete the original hotbar.json that lies within AppData\LocalLow. (~/.config/unity3d/LoE/Legends of Equestria if on Linux)
  3. Relaunch the game, log in as usual, and move some skills about in your randomized hotbar, this will trigger the creation of a new hotbar.json.
  4. Exit the game again.
  5. Replace the new hotbar.json with the copy you had from the first step
  6. Relaunch the game and log in again and you should have your customized hotbar working again.
justin raised the priority of this task from Needs Triage to Unbreak Now!.
justin added a subscriber: justin.

thanks @JenniTheDragon for the repro steps

justin closed this task as Resolved.Oct 17 2017, 7:25 PM

fixed 10-17-2017 with client commit 737ef3c9