Justice's Blind Eye - Quest Not Continuing
Closed, ResolvedPublic

Description

What is happening:
After finding True Vision's brooch and giving it to him, I tend return to Eagle Eye to give her the news... but when I talk to her, the quest will not continue or complete.

What should be happening:
Speaking with Eagle Eye should complete/continue the quest, but she just gives the usual normal dialog, thus preventing progression.

Steps to reproduce the issue:
Continue Justice's Blind Eye until you get to the objective 'Give Eagle Eye the news', which then she just gives default dialog.

Reproduced by:
N/A

Screenshots:
N/A

Tykune created this task.Sep 22 2017, 6:09 AM
Rattletrap closed this task as Resolved.Sep 30 2017, 7:16 AM

This issue has been fixed and should be available to try again after the next server restart.

Tykune reopened this task as Open.Oct 1 2017, 2:53 AM

It still isn't working for me. I tried speaking with Eagle Eye, and it still says random dialog.

Try again, please. The issue has been updated.

Rattletrap closed this task as Resolved.Oct 2 2017, 6:15 PM
Tykune added a comment.Oct 2 2017, 7:10 PM

Well, this time she wont talk to me period. When I try to speak with her, nothing happens.

Tykune reopened this task as Open.Oct 2 2017, 7:10 PM

What other quests do you have open or completed in the CK?

Tykune added a comment.Oct 7 2017, 7:49 PM

None. She is my last quest.

Annri added a subscriber: Annri.Oct 9 2017, 3:16 PM

I have the issue that I can't speak with her and start this quest! I tried it with 2 accounts: 1 with most other quests completed and the other one with almost no other quest completed. The same happened to someone else 6 hours ago.

Annri added a comment.Oct 10 2017, 7:44 PM
In T1679#27066, @Annri wrote:

tried with 2 accounts: 1 with most other quests completed and the other one with almost no other quest completed

Now she tells me random things but I can't speak with her/offer my help. I've completed this quest approximately 2 weeks ago with another character and everything went flawless.

Rattletrap closed this task as Resolved.Oct 11 2017, 2:43 AM

This issue has been fixed. The quest is now a foal only quest as it was originally supposed to be. If you are currently adult, you will be able to finish out the quest. If you are still a foal, completing the quest will allow you to unlock Eagle Eye's second foal quest, Eye Sore.

Annri added a comment.Oct 11 2017, 4:41 AM

This issue has been fixed. The quest is now a foal only quest as it was originally supposed to be. If you are currently adult, you will be able to finish out the quest. If you are still a foal, completing the quest will allow you to unlock Eagle Eye's second foal quest, Eye Sore.

The second quest Eye Sore cannot be started, even as a foal.
Because we weren't aware of this is supposed to be a foal only quest, I wanna suggest you to think about it. Please, add any second option to start both quests as an adult pony.
I just walked through the quest as a foal and don't understand why it should be foal only and there is nothing written in the wiki.
It really doesn't feel like it should be a foal only quest unlike Can You Hear Me Now.
It's a quest in Crystal Kingdom which never looked to me like it should be a foal only quest. If you don't change it again, many players will miss both quests for nothing.

Without any announcement or hint making this a foal only quest, I think this is not fair.

Annri added a comment.EditedOct 11 2017, 5:09 AM

This issue has been fixed. The quest is now a foal only quest as it was originally supposed to be. If you are currently adult, you will be able to finish out the quest. If you are still a foal, completing the quest will allow you to unlock Eagle Eye's second foal quest, Eye Sore.

I just reloaded Crystal Kingdom and had access to the second quest!
I got rewarded with Sunglasses I can only obtain through this quest.

Are you extremely sure that both quests should remain restricted? If that's the case, I must delete a character where I put a lot of work in.

And for some reason, 2 and a half hotbar pages are now full of ground pound and bubble barrage. Not sure where this is coming from.