Linux launcher/client doesn't work
Open, HighPublic

Description

Downloaded the Linux launcher/client for LoE and it won't launch. Running from file with the 64bit excutable results in a quick small window then it closes with nothing happening afterwards, and literally nothing happens when trying to run the 32bit executable.

I tried to run from terminal to see outputs this what I got;

(censored)@(censored):~/Downloads/LoE_linux_0.1.8_f621f00$ ./loe.x86_64
Set current directory to /home/(censored)/Downloads/LoE_linux_0.1.8_f621f00
Found path: /home/(censored)/Downloads/LoE_linux_0.1.8_f621f00/loe.x86_64
Mono path[0] = '/home/(censored)/Downloads/LoE_linux_0.1.8_f621f00/loe_Data/Managed'
Mono path[1] = '/home/(censored)/Downloads/LoE_linux_0.1.8_f621f00/loe_Data/Mono'
Mono config path = '/home/(censored)/Downloads/LoE_linux_0.1.8_f621f00/loe_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 2 screens
displaymanager screen (0)(VGA-1): 1024 x 768
Using libudev for joystick management


Importing game controller configs

(censored)@(censored):~/Downloads/LoE_linux_0.1.8_f621f00$ ./loe.x86
bash: ./loe.x86: No such file or directory
mrkline67@Nexcore-U4500:~/Downloads/LoE_linux_0.1.8_f621f00$ dir
loe_Data  loe.x86  loe.x86_64

Running Ubuntu 17.04 (64bit)
Processor: Intel Core 2 Duo (3 GHz ea) (E8400)
Graphics: Intel Q45/Q43, 256 VRAM, (OpenGL 2.1)
Ram: 4GB

LeafyGrove created this object in space S1 LoE.
LeafyGrove created this object with edit policy "Custom Policy".
SpeciallyTrainedDerp added a comment.EditedSep 18 2017, 8:25 PM

I'm suffering the same problem. A blue window jumps up and disappears again.

std@P-21 ~/Downloads/Legends of Equestria/LoE_linux_0.1.8_f621f00 $ ./loe.x86_64 
Set current directory to /home/std/Downloads/Legends of Equestria/LoE_linux_0.1.8_f621f00
Found path: /home/std/Downloads/Legends of Equestria/LoE_linux_0.1.8_f621f00/loe.x86_64
Mono path[0] = '/home/std/Downloads/Legends of Equestria/LoE_linux_0.1.8_f621f00/loe_Data/Managed'
Mono path[1] = '/home/std/Downloads/Legends of Equestria/LoE_linux_0.1.8_f621f00/loe_Data/Mono'
Mono config path = '/home/std/Downloads/Legends of Equestria/LoE_linux_0.1.8_f621f00/loe_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 3 screens
displaymanager screen (0)(LVDS1): 1280 x 800
Using libudev for joystick management

"client has 3 screens"?
I'm guessing it's pointing out I have 3 possible outputs, but I'm only using 1 screen.

I'm using Linux Mint 18.2 Sonya 64-bit - Kernel Linux 4.10.0-35-generic x86_64 - MATE 1.18.0
Intel® Core™2 Duo CPU T5750 @ 2.00GHz
4GB of RAM

I've ran the betas in the past with little issue.

The Linux client works for me, though I'm running Gentoo.

glxgears-info starts out with:

GL_RENDERER = Mesa DRI Intel(R) Sandybridge Mobile
GL_VERSION = 3.0 Mesa 12.0.1
GL_VENDOR = Intel Open Source Technology Center

...and then a whole bunch of GL_EXTENSIONS. Maybe Opengl version 3 is required for this version?

@ccc_037 - I'm thinking so, especially considering you're able to play in linux and your GPU handles OpenGL 3.0, which sucks because that means I can't p lay this on linux at least until I can grab a better PC or can perhaps get a graphics card thaat handles at least OpenGL 3.0 for this desktop.

I know it's not ideal, but I found that running it as root, using su, does fix the problem for me.
Just in case anyone wanted to give it a go.

I know it's not ideal, but I found that running it as root, using su, does fix the problem for me.
Just in case anyone wanted to give it a go.

I would highly not recommend running most programs as root

As for running the client on linux, make sure you have a working graphics driver as well as OpenGL >=3.0