Quick Bits
Closed, ResolvedPublic

Description

What is happening:
Players are able to obtain "Moonlight Back Legs" which sell for 4300 bits each. The drop rate of the mobs who drop the item has a high percentage rate.

What should be happening:
Players should not be making this much bits in a short amount of time. Especially if all they have to do is aggressive a group of mobs and use one ability that kills them instantly. Requiring no effort to gain bits. The drop rate should be set higher, making it harder to obtain these armor pieces.

Steps to reproduce the issue:
Once in Evershade forest go to the way back where the Pegasus Rock Golems are located, there is dragons chilling on a hill in a cluster. Run in the middle of them and then use Stored Strike to instantly kill all of them. After, loot all the drops and use Stored Strike again, as the mobs have already spawned and started attacking. The loot varies from 450+ to 600 bits as well dropping Moonlight Back Legs. I have received about 25 Moonlight Back Legs from just killing them for 30 minutes, which they sell for 4300 each. However I stumbled upon this after farming the level 65 dragon for bits as they drop 4000+ bits each defeat, but have came across this and noticed players have found out about this.

Game client version:
Build : v 0.1.8

Reproduced by:
I have stumbled upon this with a friend. Don't know if the issue is being dealt with.

Reproduced on:
Windows 7 (64-bit)

Crash logs or exceptions generated:

Screenshots:
http://prntscr.com/glajff - The Armor
http://prntscr.com/glal1y - Hill the Dragons rest on

Side Note:
I would like to say that I heard rumor that the Pegasus Rock Golems (level 50 and level 45) drop armor pieces as well quite frequently like the dragons. Hopefully you understand what I am trying to report.

Huski created this task.Sep 14 2017, 11:48 PM

This is more of the fault of stored strike making this easy, not the drop rate itself. If stored strike eventually gets it proper nerf, no one will be able to easily farm bits so quickly. Also the higher drop rate would be fine since at the moment the dragons spawn super quick, you have little time to go grab your loot so it comes at a high risk if you couldn't one shot and you get ganged up on.

Since Stored strike the problem here, even if they make the drop rate of these items much more rare, it wouldn't stop them from finding another bit source.

Huski added a comment.Sep 15 2017, 1:49 AM

Still you could run them away from their starting zone like I've seen which causes easy loot. Either way they still drop frequently.

Rattletrap closed this task as Resolved.Sep 7 2018, 9:54 PM
Rattletrap added a subscriber: Rattletrap.

Issue has been resolved with changes to mob drop rates and skill power levels.