Mindless Violins/It Belongs in a Museum Dialogue and Quest Marker Glitches [Unable to Complete]
Closed, ResolvedPublic

Description

What is happening:
During the "Mindless Violins" and the "It Belongs in a Museum" quests, Quest Marker glitches and broken dialogue with Silver Hoof.
Pyrite remains throughout the entirety of the two quests (up until your first dialogue with Silver Hoof that I am aware of) with a quest marker above his head.
Upon trying to talk to Silver Hoof and selecting the "I need some information about a statue" dialogue option, the dialogue is closed completely.
Silver Hoof lacked a quest marker here, as well, despite having the option (somewhat) to select the aforementioned dialogue option.
[I should mention that within my journal the next documented step of the quest is to "Find Silver--Hoof". All other steps appear completed.]

What should be happening:
After completing the appropriate steps of both quests involving Pyrite, the marker should disappear.
Silver Hoof should have a quest marker in the second quest, and the dialogue should continue as normal.

Steps to reproduce the issue:
Launch the game, using the 0.4 Launcher, and log in (Server in question was Amareicas from the beginning of Mindless Violins and onward, but I believe changing servers made no difference here).
Begin the quest "Deleting Cookies and Collecting Data", complete it.
Begin Mindless Violins, and complete steps accordingly. (By now, Pyrite's exclamation point/quest marker does not leave.)
Complete Mindless Violins, [albeit slightly disoriented by a lack of direction caused by a magical quest marker in the Heartlands], and move on to It Belongs in a Museum.
Somewhere throughout It Belongs in a Museum, after consulting Fire Opal, you are instructed to talk to Silver Hoof. Once more, there was no quest marker on the map to indicate this, aside from that of Pyrite's quest marker which had been there for an hour before.

Game client version:
v 0.1.8, as of 11.09.17 (dd/mm/yy)

Reproduced by:
User "LittleBolt" had similar issues in the same quest, however, only dialogue-related and with another NPC.

Reproduced on:
Windows 7, x64

Crash logs or exceptions generated:
N/A

Screenshots:
N/A

tigerly created this task.Sep 11 2017, 3:17 AM

(Turns out that if you talk to Pyrite, you can endlessly complete Fire Opal's "it's cursed" dialogue, but Silver Hoof still can't be spoken to and the quest marker for Pyrite remains.)

I was having a similar issue with the dialogue hanging, but on the stage of the quest where Astral asks you to call Pyrite a moron. After trying over and over again i managed to finally get the quest to update by choosing all the secondary dialogue options

tigerly reassigned this task from justin to Rattletrap.Sep 12 2017, 5:17 AM
tigerly edited projects, added scripting; removed loe-team.
tigerly added a subscriber: justin.

I went back to see if Pyrite gives this quest and thankfully he does now, however when I need to talk to Silver-Hoof about it, the dialog will instantly close, when I ask about the statue, there nothing I can do to advance it.

I have the same problem.

Rattletrap closed this task as Resolved.Sep 17 2017, 9:02 AM

These issues should all be fixed on the next server reset.