Rehearsal Roundup Quest Marker Issues
Closed, ResolvedPublic

Description

What is happening:
its showing that ponys have quests but when i talk to them its not giving or doing the quest that am on with

What should be happening:
it should continue the quest or the quest marks should go away

Steps to reproduce the issue:
it started when i got the quest to hand out music on crystal kingdom

Game client version:
V0.1.8

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Reproduced on:
LOE V0.1.8 on MACBook

Crash logs or exceptions generated:
If applicable, give a link to an archive containing the crash logs generated, or copy/paste exceptions you got related to this error

Screenshots:
https://imgur.com/a/iARBR i click on all these quests nothing happens

Liam3108 created this task.Sep 10 2017, 7:31 PM

I have this problem too.
A good thing to add while fixing it would be the ability to hide questmarkers for specific quests, so it hides the markers of the "broken" quests...
Also, maybe a button that makes you "abandon" a quest. That would make the quest deleted from journal with the possibility to redo it by speaking at the quest giver. Of course, finishing the quest would make it not abandonable anymore :p

Liam3108 raised the priority of this task from Needs Triage to High.Sep 14 2017, 7:22 PM

Having the same issue with a Quest marker not going away.

I completed the Quest: "Supply the Hospital" but Nurse Coldhoof still has a quest marker above her. The journal entry is down at the bottom but the last step of the quest looks to be active still.

Game client version:
V 0.1.8

Reproduced on:
Windows 7 64 bit

Screenshots:

Candel added a subscriber: Candel.Sep 15 2017, 12:31 AM

Also having this issue. The quest marker on Pumpkin Pie won't go away after doing the quests involving him and Beet. The marker stays even after logging out and restarting the game.

An example of the issue.

I have the same issue, this is also occurring after completion of Pyrite's quest where Pyrite will have a permanent quest marker, this also happens with Loadsa Monet in Cloudopolis after completing her part of Pyrite's quest and her personal quest and even after Noterize's quest.. Another bug in Pyrite's quest is when you need to speak with Silver-Hoof which has no quest icon. I also seem to be getting quest markers stuck on actual players, one such players name was "Honey Dew". I also seem to have a quest stuck on a Cantermore guard at the front gate whom I can speak to, but when I click to speak with her no dialogue appears and nothing happens. Another character in Cantermore seems to be bugged, "Midnight" her singing quest cannot be completed as when you move to the second mark on the map she won't sing, but when you move closer she will causing you to go back a step and repeat it. I also found that while I was flying in Cantermore I randomly got the dialouge while flying. At first I thought this was a simple error since I was was typing in the Cantermore-Cloudopolis tele. But I'd been interrupted by Midnight and sent back to Cloudopolis because when she did I jumped. I came back and was instantly greeted with the same dialogue box, the first one where she finishes singing.

Screenshots:
Midnight mid air random dialogue

Rattletrap removed a project: loe-team.
Rattletrap added a subscriber: justin.
MrSev added a subscriber: MrSev.Sep 17 2017, 2:22 PM

Please remember to report issues as individual problems. I am working on several of these issues, but because many of them are for different quests and different reasons, I cannot close this report until all of them are fixed -- which may take a long time depending on the cause.

Of course, I'll keep that in mind for next time. I simply figured since everything was similar and the subject matter was just quests that I'd put it all in one so there wouldn't be a need to look through a bunch of different posts.

Same issue with Crystal Kingdom NPCs. They still have yellow marks above them after the Rehearsal Roundup quest, I completed the quest with out giving all the papers to all the npcs. the 2 in the gym area would not give any dialog to accept the paper. Also. the 2 npcs on the outer part of the city I think "Its all about me" the ones that asks u to go get ther a bunch of things and is very rude. still has yellow mark but i don't know what to do. nothing in the journal.

Rattletrap renamed this task from Quests to Rehearsal Roundup Quest Marker Issues.Oct 2 2017, 7:26 AM
Rattletrap closed this task as Resolved.Aug 5 2018, 6:17 PM

This issue has been resolved. Closing it up now.