Losing Items while they are equipped when logging out or zoning to a new room
Closed, WontfixPublic

Description

What is happening:
If you have items equipped to you, zoning to a new room will make these items disappear

What should be happening:
Shouldn't lose any equipped items when log out/moving to a new room

Steps to reproduce the issue:
Put on items from your inventory (Except the headphones, some reason they persist even during this) and move to a new room, or log out and back in. You'll lose them afterwards.

Game client version:
Launcher 0.3, Vers. 0.1.6b. Windows 64x

Reproduced by:
Dorumon21 and probably several others

Reproduced on:
Window 10, 64x

Crash logs or exceptions generated:

Screenshots:

Dorumon21 updated the task description. (Show Details)
Xiron added a subscriber: Xiron.Aug 12 2017, 10:35 PM

Headphones aren't excluded. There seems to be an odd case where an item sometimes won't disappear. Had it happen with the mountain flower where in vanished for someone but not for I.

I've run into this bug as well. The only wearable items that persist through changing zones were items that I was wearing last time I played (which was a few weeks ago). However, if I removed an item and re-equipped it, then changed zones, it disappeared. Also, I have the Lantern equipped to my character and cannot remove it. (The Lantern was one of the items that I had equipped the last time I played) It does not display where a held item like the Lantern should be on my character's info screen, and attempting to equip the second Lantern I had in my inventory did nothing. In addition, anything purchased or added to inventory persists when changing zones.

I've tried to attach a video demonstrating this. On a side note, it also shows an animation glitch with the wearable Boots item and how the NPC Shop windows will not disappear when clicking the red X. Sometimes hitting ESC worked but it didn't in the video; I had to select the Shop option again by clicking the NPC.

I was playing on a Windows 10 64-bit PC, Launcher 0.3 and on game build v0.1.6

justin closed this task as Wontfix.Aug 14 2017, 8:03 PM
justin lowered the priority of this task from Needs Triage to Low.

This is due to a change to the items database. It only affects older servers, and we haven't updated client/servers yet.