heavy fps issue + game is being slow
Closed, InvalidPublic

Description

What is happening:

  • I'm getting only 10-20fps in average, which is highly unusual with my setup. Game also occasionally freezes for few short moments.
  • SETUP: i5-4460, GTX 1060 6GB, 8Gb RAM, H97M-D3H, 600W
  • OS: Windows 10 64-bit
  • LoE is installed on my 1TB hard drive with 500Gb of free space in it
  • I tried to put LOWEST graphic settings, but that didn't help any either.
  • I have tried other games, to eliminate failures in components and I had NO ISSUES with them.
    • GPU drivers are also up to date.
    • Load times between maps have also suddenly increased.

~ If I missed anything, I'll gladly provide more information
What should be happening:
I should be getting high fps, smooth gameplay with faster load times

Steps to reproduce the issue:
I have asked others if they have this issue, and so far nobody has had it.

Game client version:
0.1.6
I also tried 0.1.4 client, and issues were there too.

Reproduced by:
Forum name of anyone having reproduced this issue, if any

Reproduced on:
List of operating systems this issue has been reproduced on, including their version number if available, and their architecture (32 bit or 64 bit)

Crash logs or exceptions generated:
If applicable, give a link to an archive containing the crash logs generated, or copy/paste exceptions you got related to this error

Screenshots:
https://www.dropbox.com/home?preview=Desktop+04.22.2017+-+11.40.41.05.mp4
recorded in 30fps 1080p, might give false info.
However; trust me, it is 10-20fps if you came to look on my screen.

Blueprint added a subscriber: Blueprint.EditedApr 26 2017, 7:11 AM

Hm, I have a similar problem, might be related.
The game logs an unsupported shader (Toon/Basic NDOutline) and tons of NullReference Exceptions.
Barely runs at 5 FPS, the input is extremely delayed. Klicks on the menus are delayed even more.
CPU usage is only 8% and GPU Usage is only 18%, while the hard drive is insanely busy with 80+%.
Note: Main Menu and Character Select/Creation are working fine. Loading and rendering the world seems to trigger the problem.
Also, loading takes a while, as Grendster already stated.

Log file: https://www.dropbox.com/s/yssmsefuvdkduj2/output_log.txt?dl=0

Tested with Build 0.1.6, I wasn't at home to play the game for some months, so I can't say if this is only a problem of the current build.
EDIT: Same problem with previous Builds.
Other games are running fine.
System used:
Windows 10 Pro 64-bit (10.0, Build 14393)
Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
NVIDIA GeForce GTX 960 2GB
16GB RAM
Recent drivers.

I have slightly lower specs, yet I usually get between 45-60 fps on outdoor maps. There is a new command, called /setfps that does limit FPS. It can limit FPS to as low as 15 fps, to as high as 160 fps (0.1.4),or 1000 fps (0.1.6). Make sure that's set to the max and VSync is turned off.

And double check to see if there's any programs running that could hinder performance. Running a bunch of programs at once does sometimes reduce the framerate due to to the load on the CPU and the GPU.

I had an issue with 0.1.4 for a while to where I could only get mid 30's to mid 40's on outdoor maps while using Wi-Fi. Switching to Ethernet increased framerates by 10-15 fps, and brought indoor map framerates back to over 100.

Here's my specs:
Intel Core i5 4430
EVGA GeForce GTX 1060 3 GB SC
12 GB RAM
Windows 10 Home 64-bit.

Blueprint added a comment.EditedApr 27 2017, 3:07 PM

I made a forum post about it, since it might be just a problem on my/our end.
http://forum.legendsofequestria.com/index.php?topic=16621

So I was able to bypass the problem. The game encounters some errors, they get logged and that seems to slow it down.
The drive is writing over 8MB/s, which is a whole lot.
In the games files (LoE_Launcher\game\LoE_Data) there is the Output_log file. If you make this file read-only, it should "solve" the performance issue.
The real question is, why is this only happening to very few people and what exactly is causing it?

I'm just here updating on my part, and I don't know what exactly has been updated or so, but my FPS issues seem to have gone away. I haven't had them in a while, which is a good thing.
I'll keep updating on my part, if I still keep getting the issue.

justin closed this task as Invalid.Jun 30 2017, 1:29 AM