Crash on exit
Closed, WontfixPublic

Description

What is happening:
Attempted to exit game. Game crashed and froze partway through exit.

What should be happening:
Client should exit smoothly.

Steps to reproduce the issue:
...unfortunately, no idea what I could have done to trigger this. (I have on occasion seen a segfault on exit. I fear this may be a memory corruption issue, which will be a real pain to nail down if so.)

Game client version:
0.1.4 (archive LAR_linux_2017_02_07_55a550f.zip)

Reproduced on:
64-bit Linux

Crash logs or exceptions generated:
I have a 70-odd meg player.log file. I've copied the last about half-a-meg to pastebin on the theory that there is probably some hint as to what happened at the end of the program near the end of the file (and because pastebin has a half-a-meg size limit), but if you want the whole 71M file I could send it. (There's an awful lot of NullReferenceExceptions in there.)

ccc_037 created this task.Apr 9 2017, 3:55 PM
justin closed this task as Wontfix.Jun 30 2017, 1:32 AM