No Kill Plane Beneath Heartlands
Closed, ResolvedPublic

Description

What is happening:
When players glitch and fall beneath the Heartlands, there is no kill plane that respawns the player. Instead, the player falls onto an invisible surface below the ground, able to walk freely across the entire Heartlands map.

It is far enough below that unicorns are not able to teleport back up, and logging out and back in does not automatically return the player to the surface. The only way to get out of this situation is to use the /stuck command. (Which, if I am right, will be removed upon release.)

Aside from the teleportation glitch (near the burnt-out area in the Heartlands) that got me under here, a kind of glitch that has been reported before, there should always be contingency plans for future glitches that may not be caught. Therefore, there should be something underneath the Heartlands that is similar in function to the plane below Cloudsdale.

This was found on version 0.1.4, on a Linux 64-bit system.

Asriel created this task.Mar 9 2017, 1:50 AM

Oh, and I didn't report the teleportation glitch near the burnt-out area, mostly because I have not been able to reproduce it, and I have no idea exactly how it happened.

I suspect it is the same as the other teleport glitches that push you through the floor, and so it is not high on my list of priorities.

justin reassigned this task from justin to SavanaPope.Jun 30 2017, 1:38 AM
justin lowered the priority of this task from Needs Triage to Normal.
justin edited projects, added client; removed loe-team.
justin added a subscriber: justin.
Xiron closed this task as Resolved.Jul 12 2017, 3:50 AM